0
Enquiry £0.00
0
Basket
£0.00
Loading...
Loading...
Enquiries and orders updates!
Enquiries and orders updates! Enquiries and orders updates!
The item is out of stock.
We are sorry but the item is out of stock.

PLANET LRP-1622CS network switch Managed L2/L4 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) 1U Blue

Part number: LRP-1622CS
EAN: 4711605281294
£1,171.89 ex VAT
£1,406.27 inc VAT
Availability:
31-40  pcs
Order within: 13h 20min

The estimated delivery time is provided by the carriers. It allows you to determine the expected date when your order will reach you.

Delivery
Wednesday, 28 October 2026
£19.87
Fastest delivery
Tuesday, 27 October 2026
Payment methods
Visa Mastercard Paypal Apple Pay Google Pay
Delivery methods
UPS Standard InPost Paczkomaty 24/7 FedEx PL Schenker Kuehne Nagel RABEN

> Physical Port

> 16 100Mbps BNC female ports with Long Reach PoE Injector function

> 2 10/100/1000BASE-T Gigabit RJ45 copper ports

> 2 100/1000BASE-X mini-GBIC/SFP slots

> RJ45 console interface for switch basic management and setup

> Long Reach Power over Ethernet

> Supports PoE power up to 36 watts for each PoE port

> Remote power feeding up to 1 kilometer with 5C2V/RG6 75Ω coaxial cable

> Long Reach PoE Management

> Total Long Reach PoE power budget control- Per port Long Reach PoE function enable/disable- Long Reach PoE port power feeding priority- Per Long Reach PoE port power limitation- Long Reach PD alive check- Long Reach PoE schedule

> Layer 2 Features

> Prevents packet loss with back pressure (half-duplex) and IEEE 802.3x pause frame flow control (full-duplex)

> High performance Store and Forward architecture, broadcast storm control, runt/CRC filtering that eliminates erroneous packets to optimize the network bandwidth

> Supports VLAN- IEEE 802.1Q tagged VLAN- Provider Bridging (VLAN Q-in-Q, IEEE 802.1ad) support- Protocol VLAN- Voice VLAN- Private VLAN- Management VLAN- GVRP

> Supports Spanning Tree Protocol

> STP (Spanning Tree Protocol)- RSTP (Rapid Spanning Tree Protocol)- MSTP (Multiple Spanning Tree Protocol)- STP BPDU Guard, BPDU Filtering and BPDU Forwarding

> Supports Link Aggregation

> IEEE 802.3ad Link Aggregation Control Protocol (LACP)- Cisco ether-channel (static trunk)- Maximum 4 trunk groups, up to 4 ports per trunk group

> Provides port mirror (many-to-1)

> Loop protection to avoid broadcast loops

> Quality of Service

> Ingress/egress rate limit per port bandwidth control

> Storm control support

> Broadcast / unknown unicast / unknown multicast

> Traffic classification

> IEEE 802.1p CoS- ToS/DSCP/IP Precedence of IPv4/IPv6 packets

> Strict priority and Weighted Round Robin (WRR) CoS policies

> Multicast

> Supports IGMP snooping v2 and v3

> Supports MLD snooping v1, v2

> IGMP querier mode support

> IGMP snooping port filtering

> MLD snooping port filtering

Ideal solutions for your business Ideal solutions for your business
We find the optimal solution for your business. Our sales and presales specialists select products and services for our customers every day.
Express delivery of equipment worldwide Express delivery of equipment worldwide
We guarantee on-time delivery of your equipment wherever you are. We work with global partners to ensure our logistics are optimised.
Implementation support guaranteed Implementation support guaranteed
We offer support in implementing solutions in your business. Our qualified engineers help you manage your infrastructure effectively.
Customer first Customer first
Our RMA experts deal with complaints and equipment replacements quickly and efficiently, so that your business can run smoothly.

Description

PLANET LRP-1622CS. Switch type: Managed, Switch layer: L2/L4. Basic switching RJ-45 Ethernet ports type: Gigabit Ethernet (10/100/1000), Basic switching RJ-45 Ethernet ports quantity: 2, Console port: RS-232. Full duplex. MAC address table: 8000 entries, Switching capacity: 11.2 Gbit/s. Networking standards: IEEE 802.1D, IEEE 802.1Q, IEEE 802.1ab, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.1x, IEEE.... Power over Ethernet (PoE). Rack mounting, Form factor: 1U

Multimedia

Manual (PDF):

Other Digital Assets:

Specifications

Management features
Switch type 
Managed
show more
Switch layer 
L2/L4
show more
Web-based management 
Yes
show more
Quality of Service (QoS) support 
Yes
show more
ARP inspection 
Yes
show more
Traffic classification 
Yes
show more
System event log 
Yes
show more
MIB support 
RFC 1213 MIB-II, RFC 1215 Generic Traps, RFC 1493 Bridge MIB, RFC 2674 Bridge MIB Extensions, RFC 2737 Entity MIB (Version 2), RFC 2819 RMON (1, 2, 3, 9), RFC 2863 Interface Group MIB, RFC 3635 Ethernet-like MIB
show more
Optical fiber
Fiber ethernet cabling technology 
1000BASE‑LX, 100BASE-FX, 100BASE-SX
show more
Transmission distance (max) 
2 km
show more
Fiber type 
Multi-mode
show more
Security
Security algorithms 
128-bit AES, SNMP, SSH, SSL/TLS
show more
MAC address filtering 
Yes
show more
DHCP features 
DHCP client, DHCP server
show more
Access Control List (ACL) 
Yes
show more
IGMP snooping 
Yes
show more
Admin-edge port 
Yes
show more
IP-MAC-Port binding 
Yes
show more
BPDU filtering/protection 
Yes
show more
Loop protection 
Yes
show more
SSH/SSL support 
Yes
show more
Static port security 
Yes
show more
Authentication 
Port-based authentication
show more
Multicast features
Multicast support 
Yes
show more
Number of multicast groups filtered 
256
show more
Power over Ethernet (PoE)
Power over Ethernet (PoE) 
Yes
show more
Power over Ethernet (PoE) ports quantity 
2
show more
Power over Ethernet plus (PoE+) ports quantity 
2
show more
Total Power over Ethernet (PoE) budget 
440.0000
show more
Ports & interfaces
Console port 
RS-232
show more
Basic switching RJ-45 Ethernet ports quantity 
2
show more
Basic switching RJ-45 Ethernet ports type 
Gigabit Ethernet (10/100/1000)
show more
Compatible memory cards 
Not supported
show more
SFP module slots quantity 
2
show more
Performance
Firmware upgradeable 
Yes
show more
Maximum cable length 
1200.0000
show more
Network
10G support 
No
show more
Networking standards 
IEEE 802.1D, IEEE 802.1Q, IEEE 802.1ab, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.1x, IEEE 802.3, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3u, IEEE 802.3x, IEEE 802.3z
show more
Copper ethernet cabling technology 
10BASE-T, 100BASE-T, 1000BASE-T
show more
Flow control support 
Yes
show more
Port mirroring 
Yes
show more
Full duplex 
Yes
show more
Rate limiting 
Yes
show more
Broadcast storm control 
Yes
show more
Auto-sensing 
Yes
show more
VLAN support 
Yes
show more
Spanning tree protocol 
Yes
show more
MAC address auto-aging supported 
Yes
show more
Auto MDI/MDI-X 
Yes
show more
Auto-negotiation 
Yes
show more
MAC address auto-learning supported 
Yes
show more
Link aggregation 
Yes
show more
Virtual LAN features 
Port-based VLAN, Private VLAN, Protocol-based VLAN, Tagged VLAN
show more
Design
Rack mounting 
Yes
show more
Product colour 
Blue
show more
Stackable 
Yes
show more
Form factor 
1U
show more
LED indicators 
Yes
show more
On/off switch 
Yes
show more
Number of fans 
3 fan(s)
show more
Housing material 
Metal
show more
Reset button 
Yes
show more
Certification 
FCC Part 15 Class A, CE
show more
Packaging data
Rack mount kit 
Yes
show more
Quick start guide 
Yes
show more
Cables included 
RS-232
show more
Rubber feet 
Yes
show more
AC adapter included 
Yes
show more
Operational conditions
Storage relative humidity (H-H) 
5 - 95
show more
Storage temperature (T-T) 
-10 - 70
show more
Operating relative humidity (H-H) 
5 - 95
show more
Operating temperature (T-T) 
0 - 50
show more
Packaging content
Rack mount kit 
Yes
show more
Quick start guide 
Yes
show more
Cables included 
RS-232
show more
Certificates
Certification 
FCC Part 15 Class A, CE
show more
Data transmission
Switching capacity 
11.2 Gbit/s
show more
MAC address table 
8000 entries
show more
Store-and-forward 
Yes
show more
Jumbo frames support 
Yes
show more
Jumbo frames 
10
show more
Power
Input voltage 
52 V
show more
AC input voltage 
100 - 240 V
show more
Power supply included 
No
show more
Power consumption (typical) 
540.0000
show more
AC input frequency 
50 - 60 Hz
show more
Weight & dimensions
Depth 
300 mm
show more
Width 
440 mm
show more
Height 
44.5 mm
show more
Weight 
4430 g
show more
SKU: 1624688
Stay in touch!
Join our newsletter and stay up to date with our promotions and news.

By clicking "Subscribe" you agree to receive marketing information at your e-mail address. Your personal data will be administered by Senetic LTD with its registered office in 3 More London Riverside, London SE1 2RE, United Kingdom. You have the right to demand access to personal data and to rectify, erase or limit the processing, as well as to object to the processing. Detailed information on the processing of personal data can be found in the privacy policy.

Incorrect e-mail address
This e-mail address has already been confirmed.
This e-mail address has not been confirmed yet.
Thank you!
Check your inbox - you will receive a message from us asking you to confirm your subscription to the newsletter.
Reseller portal
Everything you are looking for
Microsoft
Full range of Microsoft solutions
Please wait ...
Compare (0/4)